CloudStack: cloud-agent dead but subsys locked (continued)


I thought I’d continue on this topic for those who may be having different issues for the cloudstack-agent not starting. First thing you should do is check your logs and in one case I was able to reproduce this issue.

[root@cldstkkvm02 ~]# tail /var/log/cloudstack/agent/agent.log
2013-07-05 22:41:53,691 INFO  [cloud.agent.AgentShell] (main:null) Agent started
2013-07-05 22:41:53,693 INFO  [cloud.agent.AgentShell] (main:null) Implementation Version is 4.1.0
2013-07-05 22:41:53,694 INFO  [cloud.agent.AgentShell] (main:null) agent.properties found at /etc/cloudstack/agent/agent.properties
2013-07-05 22:41:53,696 INFO  [cloud.agent.AgentShell] (main:null) Defaulting to using properties file for storage
2013-07-05 22:41:53,698 INFO  [cloud.agent.AgentShell] (main:null) Defaulting to the constant time backoff algorithm
2013-07-05 22:41:53,777 INFO  [cloud.agent.Agent] (main:null) id is
2013-07-05 22:41:53,781 ERROR [cloud.resource.ServerResourceBase] (main:null) Nics are not configured!
2013-07-05 22:41:53,787 INFO  [cloud.resource.ServerResourceBase] (main:null) Designating private to be nic cloudbr0
2013-07-05 22:41:53,799 INFO  [resource.virtualnetwork.VirtualRoutingResource] (main:null) VirtualRoutingResource _scriptDir to use: scripts/network/domr/kvm
2013-07-05 22:41:54,017 ERROR [cloud.agent.AgentShell] (main:null) Unable to start agent: NO HVM support on this machine, please make sure: 1. VT/SVM is supported by your CPU, or is enabled in BIOS. 2. kvm modules are loaded (kvm, kvm_amd|kvm_intel)

The key point in this log is the “ERROR” which states “Unable to start agent: NO HVM support on this machine, please make sure: 1. VT/SVM is supported by your CPU, or is enabled in BIOS. 2. kvm modules are loaded (kvm, kvm_amd|kvm_intel)

So make sure that your CPU is supported. I would assume you would have already do so and your sure that virtualization is enabled but lets check a few things.
Run this command to check if your CPU is supported.

egrep '(vmx|svm)' --color=always /proc/cpuinfo

If you ran this and got no output your CPU is probably not supported or VT is not enabled.

Run the next command.

lsmod  | grep kvm

If you ran this and got no output the kvm modules are not loaded and this is likely your problem because the libvirtd service is needed by the cloudstack-agent.

Try this to fix the problem:

yum remove cloudstack-agent -y
yum install kvm libvirt python-virtinst qemu-kvm -y
yum install cloudstack-agent -y
service libvirtd start
service libvirtd status
service cloudstack-agent start

If the libvirtd service is now running now I think we’re all good to go. You may still see the “cloudstack-agent dead but subsys locked” error when checking the status of the cloudstack-agent service. Don’t worry about it. Try to connect to the host in the CloudStack management portal or try this next step to see if it all works.

# cloudstack-setup-agent
Welcome to the CloudStack Agent Setup:
Please input the Management Server Hostname/IP-Address:[localhost]192.168.2.59
Please input the Zone Id:[default]
Please input the Pod Id:[default]
Please input the Cluster Id:[default]
Please choose which network used to create VM:[cloudbr0]
Starting to configure your system:
Configure Cgroup ...          [OK]
Configure SElinux ...         [OK]
Configure Network ...         [OK]
Configure Libvirt ...         [OK]
Configure Firewall ...        [OK]
Configure Nfs ...             [OK]
Configure cloudAgent ...      [OK]
CloudStack Agent setup is done!

If all went well you should see the above output. Hope this helps.

4 Comments

Add yours
  1. Ramzana

    Hi Hyper advisor…

    I got the cloudagent up and running, but after configuration I am not able to ping to the managment server and hence not able to add the host(hypervisor) to the Mgmnt Server.

    Any help would be appreciated…

    Thanks a lot…

    • Antone Heyward

      Not being able to ping could be a few different things on the network, dns or your firewall. You’ll have to do some basic troubleshooting for this. See if you can ping the ip of host from mgmt server and from mgmt server to host. Try disabling the firewall.

  2. Yousaf

    Still getting the following:
    [root@srvr1 ~]# service cloudstack-agent status
    cloudstack-agent dead but subsys locked

Comments are closed.